阅读 172

数据结构 09-排序3 Insertion or Heap Sort (25 分)

数据结构 09-排序3 Insertion or Heap Sort (25 分)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Heap Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

 

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

 

Sample Input 2:

103 1 2 8 7 5 9 4 6 06 4 5 1 0 3 2 7 8 9

 

Sample Output 2:

Heap Sort5 4 3 1 0 2 6 7 8 9

 

 

参考文章 https://blog.csdn.net/liyuanyue2017/article/details/84328364

#include <iostream>#include <algorithm>#include <vector>using namespace std;void printVector(vector<int> &compare){
    cout << compare.front();    for(int i=1;i<compare.size();i++){
        printf(" %d",compare[i]);
    }
}bool isInsertionSort(vector<int> &arr,vector<int> &compare){    bool flag=false;
    vector<int> sorted{arr};    int i;    for(i=1;i<sorted.size();i++){
        sort(sorted.begin(),sorted.begin()+i+1);        if(sorted==compare){
            i++;
            flag=true;            break;
        }
    }    if(flag){
        sort(compare.begin(),compare.begin()+i+1);
        cout << "Insertion Sort"<<endl;
        printVector(compare);
    }    return flag;
}void adjust(vector<int> &arr,int k,int n){    int temp=arr[k];    int parent,child;    for(parent=k;parent*2+1<n;parent=child){//找到子结点中最大的结点
        child=parent*2+1;//左子结点
        if(child!=n-1&&arr[child]<arr[child+1]){//有右子结点 且右子结点大于左子结点
            child++;
        }        if(arr[child]<=temp)break;//最大的子结点小于父结点
        else{
            arr[parent]=arr[child];
        }
    }
    arr[parent]=temp;//父子结点互换位置}void maxHeapSort(vector<int> &arr,vector<int> &compare){    //大根堆
    bool flag{false};    for(int i=arr.size()/2;i>=0;i--){
        adjust(arr,i,arr.size());
    }    
    for(int i=arr.size()-1;i>0;i--){
        swap(arr[0], arr[i]);
        adjust(arr,0,i);        if(flag)break;        if(arr==compare){
            flag=true;
        }
    }
    
    cout << "Heap Sort"<<endl;
    printVector(arr);
}int main(){    int n;
    cin >> n;
    vector<int> arr(n),compare(n);    for(int i=0;i<n;i++){
        scanf("%d",&arr[i]);
    }    for(int i=0;i<n;i++){
        scanf("%d",&compare[i]);
    }    if(!isInsertionSort(arr,compare)){
        maxHeapSort(arr,compare);
    }    return 0;
}

 

数据结构 09-排序3 Insertion or Heap Sort (25 分)

原文:https://www.cnblogs.com/ichiha/p/14811638.html


文章分类
后端
版权声明:本站是系统测试站点,无实际运营。本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌抄袭侵权/违法违规的内容, 请发送邮件至 XXXXXXo@163.com 举报,一经查实,本站将立刻删除。
相关推荐